Topic: WebApp and IE8 (not working) IE9 (Visualisation issues)

Hi,

I tried the WebApp demo page http://demo.webapp-net.com/
With two different Notebooks WinXP and IE8 as well as Win-7 IE9, and I havbe the following issues:

IE8 (on WinXP) shows "Errors on page" in the bottom of the Explorer Window and does not load the page. That's it.
The ScriptDebugger shows several errors:
Undefined:    WA.Proxy("WebApp/Proxies/ProxyJSON.php");
And in the following 3 more times:  WA is not defined.
>> This might be also an issue why it is not working with my BlackBerry (see my earlier post)

IE9 (on Win7) shows the demo seems to work correctly on the first glimps, but when you actually click on the Buttons Demo, there should be 3 Buttons on the page. It shows only the Text of the upper button but nothing else: No graphics and no other button.
There should be 3 buttons on the page with graphics, but nothing is there to see.

Does someone knows this issue or how to solve it?
Best regards,
Hauke

Re: WebApp and IE8 (not working) IE9 (Visualisation issues)

WebApp ist for WebKit not for IE

Re: WebApp and IE8 (not working) IE9 (Visualisation issues)

Indeed, ralf is right.

WebApp.Net has been design for WebKit browsers (but works in Firefox too).
There is actually no plan to support other browsers since the projet is not in so active state.

Sorry

We need Amazon reviewers. Please do one!
Book: "Beginning iPhone and iPad Web Apps: Scripting with HTML5, CSS3, and JavaScript" Buy Now! (or review).
/!\ Don't forget to "Like" WebApp.Net from the homepage

Re: WebApp and IE8 (not working) IE9 (Visualisation issues)

For info the source got is available on GitHub along with a new and rewritten WIP version

old: https://github.com/chrilith/webapp.net.alumni
new: https://github.com/chrilith/webapp.net

We need Amazon reviewers. Please do one!
Book: "Beginning iPhone and iPad Web Apps: Scripting with HTML5, CSS3, and JavaScript" Buy Now! (or review).
/!\ Don't forget to "Like" WebApp.Net from the homepage